bxm's IT Story
IPv6와 Link-local(2) 본문
## DSW2에서 CE로 IPv6 대역 ping이 안보내짐. 다시 한번 확인해보기.
## ES T
Current configuration : 2043 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DSW2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
ipv6 unicast-routing
multilink bundle-name authenticated
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 1.1.10.6 255.255.255.252
duplex auto
speed auto
ipv6 address FE80::4 link-local
ipv6 address 2001:23:23:23::4/64
!
interface FastEthernet1/0
shutdown
!
interface FastEthernet1/1
shutdown
!
interface FastEthernet1/2
shutdown
!
interface FastEthernet1/3
shutdown
!
interface FastEthernet1/4
shutdown
!
interface FastEthernet1/5
shutdown
!
interface FastEthernet1/6
switchport trunk native vlan 10
switchport mode trunk
!
interface FastEthernet1/7
shutdown
!
interface FastEthernet1/8
shutdown
!
interface FastEthernet1/9
shutdown
!
interface FastEthernet1/10
shutdown
!
interface FastEthernet1/11
shutdown
!
interface FastEthernet1/12
shutdown
!
interface FastEthernet1/13
shutdown
!
interface FastEthernet1/14
shutdown
!
interface FastEthernet1/15
shutdown
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 1.1.1.253 255.255.255.0
standby 10 ip 1.1.1.100
standby 10 preempt
!
interface Vlan20
no ip address
ipv6 address FE80::253 link-local
ipv6 address 2001:20:20:20::253/64
standby version 2
standby 20 ipv6 autoconfig
standby 20 priority 110
standby 20 preempt delay minimum 10
standby 20 track FastEthernet0/1 20
!
ip http server
no ip http secure-server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 1.1.10.5
!
!
!
ipv6 route ::/0 FastEthernet0/1 FE80::3
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
alias exec co conf t
alias exec i sh ip ro
alias exec b sh ip int br
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password cisco
login
!
!
end
어제 했던것 이어서!!
## Link-Local Unicast Address ##
- ① Interface에 IPv6 Global Unicast IP 주소가 할당되거나,
② [IPv6 enable] 명령어가 입력될 경우
Link-Local 주소가 자동으로 생성된다.
- Link-Local 주소는 [FE80::/10] 대역으로 예약되어 있으며, 하위 64bit는 'Modified EUI-64' 방식에 의해 생성된다.
(즉, MAC 주소를 사용한다.)
그리고 자동으로 생성되는 것이 아니라, 관리자가 수동으로 임의의 Link-Local 주소를 부여하는 것도 가능하다.
(주의할 점은 [FE80::/10] 대역에서만 할당이 가능하다.)
- Link-Local 주소는 외부에서 접근이 불가능하고 동일 Link 에서만 통신이 가능하다. 사용 목적은 Data 트래픽 전송이
아니라, Routing Protocol 메시지와 같은 Control 트래픽 전송 용도로 사용된다.
## IPv6 Multicast Address ##
- IPv6의 Multicast는 [FF00::/8] 대역으로 예약되어 있다.
- Broadcast가 사라지고, Multicast에게 더 많은 역할을 부여하였다.
- IPv6 Multicast 주소는 다음과 같이 분류가 가능하다.
1. Well-Known Multicast
- 예약된 Multicast 주소로 전 세계에서 통용되는 주소이다.
1) All-node multicast : [FF02::1], 모든 장비가 수신해야 하는 트래픽
2) All-router multicast : [FF02::2], 모든 Router가 수신해야 하는 트래픽
3) Solicited-node multicast
- interface에 IPv6 Unicast 혹은 Anycast 주소가 할당되었을 때 자동으로 생성되는 multicast 주소이다.
- 상위 104bit는 [FF02:0000:0000:0000:0000:0001:FF], 즉 [FF02::1:FF]로 고정되어 있고,
하위 24bit는 interface에 할당된 IPv6 Unicast/Anycast 주소의 하위 24bit 정보를 사용한다.
- IPv6 Unicast/Anycast 주소가 할당된 해당 장비만의 고유한 Multicast 주소로 사용된다.
(ex. Neighbor Discovery 등..)
4) OSPFv3, RIPng 등등 ..
2. Temparary Multicast
- 특정 Local network 관리자에 의해 생성되어 특정 Local에서만 사용되는 주소이다.
파일 구동하기!!
공통]
ena
conf t
no ip domain lookup
line c 0
logg sy
exec-timeout 0
exit
line vty 0 4
pass cisco
exit
hostname ##
end
ASW]
conf t
vlan 10
name IPv4
exit
vlan 20
name IPv6
exit
vtp mode server
vtp domain VTP02
int range f1/0 - 15
shut
exit
int f1/1
no sh
sw ac
sw ac vlan 10
exit
int f1/2
no sh
sw mo ac
sw ac vlan 20
exit
int range f1/5 - 6
no sh
sw tr enc dot
sw mo tr
sw tr native vlan 10
end
wr
DSW1]
conf t
int range f1/1 - 15
sh
exit
int f1/5
no sh
sw tr enc dot
sw mo tr
sw trunk native vlan 10
exit
vtp mode client
conf t
int f1/5
sw tr native vlan 10 ## 이 부분은 위에와 중복임. 안써줘도 될듯 ㅎㅎ.
end
wr
DSW2]
conf t
int range f1/0 - 15
sh
exit
int f1/6
no sh
sw tr enc dot
sw mo tr
sw trunk native vlan 20
exit
vtp mode client
vtp domain VTP02
int f1/6
sw tr native vlan 10
end
PC1, ASW]
conf t
no ip routing
CE]
conf t
int lo0
ip add 200.100.100.1 255.255.255.0
IPv6 add 2001:100:100:100::1/64
exit
IPv6 unicast-routing
int f0/0
ip add 1.1.10.1 255.255.255.252
IPv6 add 2001:12:12:12::1/64
IPv6 add FE80::1 link-local
exit
int f0/1
no sh
ip add 1.1.10.5 255.255.255.252
IPv6 add 2001:23:23:23::3/64
IPv6 add FE80::3 link-local
DSW1]
conf t
IPv6 unicast-routing
int f0/0
no shut
ip add 1.1.10.2 255.255.255.252
IPv6 add 2001:12:12:12::2/64
IPv6 add FE80::2 link-local
exit
int vlan 10
ip add 1.1.1.252 255.255.255.0
exit
int vlan 20
IPv6 add 2001:20:20:20::252/64
IPv6 add FE80::252 link-local
end
wr
DSW2]
conf t
IPv6 unicast-routing
int f0/1
no sh
ip add 1.1.10.6 255.255.255.252
IPv6 add 2001:23:23:23::4/64
IPv6 add FE80::4 link-local
exit
int vlan 10
ip add 1.1.1.253 255.255.255.0
exit
int vlan 20
IPv6 add 2001:20:20:20::253/64
IPv6 add FE80::253 link-local
end
wr
CE]
conf t
ip route 1.1.1.0 255.255.255.0 f0/0 1.1.10.2
ip route 1.1.1.0 255.255.255.0 f0/1 1.1.10.6
end
## default만 주면 된다.
DSW1]
conf t
ip route 0.0.0.0 0.0.0.0 f0/0 1.1.10.1
end
DSW2]
conf t
ip route 0.0.0.0 0.0.0.0 f0/1 1.1.10.5
end
CE]
conf t
IPv6 route 2001:20:20:20::/64 f0/0 FE80::2
IPv6 route 2001:20:20:20::/64 f0/1 FE80::4
DSW1]
conf t
IPv6 route ::/0 f0/0 FE80::1
## ::/0이 디폴트임.
DSW2]
conf t
IPv6 route ::/0 f0/0 FE80::3
end
## 통신 되는지 확인!! ##
DSW1]
ping 200.100.100.1
ping 2001:100:100:100::1
DSW2]
ping 200.100.100.1
ping 2001:100:100:100::1
## HSRP ##
DSW1]
conf t
int vlan 10
standby 10 ip 1.1.1.100
standby 10 priority 110
standby 10 preempt delay minimum 10
standby 10 track f0/0 20
end
wr
DSW2]
conf t
int vlan 10
standby 10 ip 1.1.1.100
standby 10 preempt
end
## IPv6 HSRP
- IPv6의 경우 HSRP를 구성할 때 반드시 HSRP version 2를 사용해야 한다.
- UDP 포트 2029번을 사용한다.
- Virtual MAC 주소는 [0075.73A0.0NNN]을 사용한다. NNN은 Group 번호를 의미한다.
- Virtual IP 주소는 Link-Local 주소가 사용되며, Autoconfig가 가능하다.
각 Group의 Virtual MAC 주소를 사용하여 EUI-64 방식으로 Virtual IP 주소의 Interface-ID를 생성한다.
- Active 장비가 전송하는 HSRP Version2 Hello 메세지의 출발지 MAC 주소는 Virtual MAC 주소가 사용된다.
Standby 장비가 전송하는 HSRP Version2 Hello 메시지의 경우 출발지 MAC 주소가 실제 장비의 MAC 주소가 된다.
* IPv6 Neighbor 테이블을 보는 명령어 - [netsh interface ipv6 show neighbor]
* IPv6 Neighbor 테이블 삭제하는 명령 - [netsh interface ipv6 delete neighbors]
DSW1]
## IPv6의 경우 Version 2라고 꼭 설정을 해줘야한다!! 위에서 설명한게 그거임!!
conf t
int vlan 20
standby version 2
standby 20 ipv6 autoconfig
standby 20 preempt
end
## standby 20 ipv6 autoconfig = virtual interface를 자동생성
DSW2]
conf t
int vlan 20
standby version 2
standby 20 ipv6 autoconfig
standby 20 priority 110
standby 20 preempt delay minimum 10
standby 20 track f0/1 20
end
## standby 확인!!
show standby vlan 20
R1]
conf t
ip default-gateway 1.1.1.100
int f0/0
no shut
ip add 1.1.1.1 255.255.255.0
end
ping 1.1.1.100
traceroute 200.100.100.1
PC2]
## 2001:200:200:200::2
## 64
## DSW2에서 show standby vlan 20에서 Virtual IP address 복사
FE80::5:73FF:FEA0:14
'Network > Cisco (KEDU)' 카테고리의 다른 글
기존 Map을 활용한 DNS와 DB file(master) - 2 (0) | 2021.07.06 |
---|---|
기존 Map을 활용한 DNS와 DB file(master) - 1 (0) | 2021.07.05 |
IPv6와 Link-local (3) | 2021.07.01 |
가상 링크 (Virtual Link) (0) | 2021.07.01 |
Full-mesh에서의 Frame-relay (0) | 2021.07.01 |